Infiniti G35 G37 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
I have a 2005 G35 Coupe 6mt with a Service Engine Light on I got the code (P0340), which is to replace the camshaft position sensor (bank1). The car drives fine and have not had any mechanical problems with it (unlike some of the other threads I read about P0340).

Here's a list of things either myself or my mechanic have tried:
1.) Replaced bank 1 camshaft position sensor with one I bought at O'Reilly's
2.) Replaced bank 1 camshaft position sensor with OEM (part# 23731-6J90D)
3.) Replaced Variable Valve Timing Solenoid (part# 23796-EG22A)
Replaced Solenoid Gasket (part# 23797-2Y50A)
Replaced Control Valve solenoid RT side (part # 23796-EA22A)

He resets the Service Engine Light - and light comes back on about 5-10miles after driving. My mechanic says he can't find anything mechanically wrong with the car and is now suggesting that I bring it to the dealer for an ECM Flash. Does this seem reasonable? Any advice on other things to look at? I'm tired of throwing money at my G, but i still love it.

Thanks
 

·
Registered
Joined
·
196 Posts
My tire dealer reset low pressure sensors a set of tires ago. Lights turned on again before buying two back ones were needed. Reset again but was told maybe new sensors on valve stem would help. No guarantee, though. Was told might just be Nissan Gremlins. Note the tire dealer used to drive Z350.

Maybe dealer can reprogram ECM or something, & might be nothing will help.
 
1 - 3 of 3 Posts
Top