Infiniti G35 G37 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello guys, I am new here obviously. I thought maybe by coming to a forum, I may find help with my current issue or guidance in the right direction to fix it.

As I was traveling around 85 ish, I went to shift into 6th gear and as I hit the clutch and moved the shifter into 6th, my car grinded and the radio screen flashed black and came back on and my shifter became locked in neutral. I tried throwing the car in gear I was rolling and could not, coasted over to the side of the road and then cut the car off and cut it back on, nothing still locked in neutral. Unplugged my battery thinking it may be something electrical and that did not work, pumped the clutch some and that did not work either. I got the car towed home and it is still sitting outside because honestly I am puzzled as to what this could be.

I recently had a clutch installed in the car about 3 weeks ago. It seemed to drive fine until now. I still here the clutch chatter and the car still cranks but I cannot put it in gear. The clutch pedal feels the same also.

Earlier that day I did however by accident take off from 4rth in a slow roll. ( i am a still learning 6spd so dont beat me up for that) The car jerk some but caught and took off but seem to shift fine after that. Hopefully that has nothing to do with my current problem?

Any help would be great. If I cant find the solution here, I will just let a shop figure it out and let you guys know what I find just in case someone else runs into this problem smh.
 

·
Super Duper Moderator
Joined
·
53,487 Posts
I've not read about a similar issue but it may be related to the clutch work you had done. Something may have become misaligned. But it's odd the radio screen would black out and come back on.
 
1 - 2 of 2 Posts
Top