Infiniti G35 G37 Forum banner

G37 convertible trunk getting stuck open while opening top

1042 Views 0 Replies 1 Participant Last post by  1998corolla
Hello everyone, I’ve read and done quite a bit of research about this specific issue yet I can’t figure it out yet why my g37 convertible 2011 keeps giving me these issues. For some background information, the top started giving me issues the day I was putting it back up but I had the car in drive in a bit of a slant downhill but when I let go off the brake thinking it was in park it started rolling then came to a sudden and quick stop after i realized what had happened and it got stuck with the trunk open but luckily pushing against the trunk we got it closed. Every time I try to open the roof the trunk only gets about 3/4 open and stops then shows me the trunk is open sign on the dashboard. The only thing you can do after that happens is turn off the car and close it after you turn it on again, but if you try to keep opening it it’ll get stuck on the trunk full open position with no way to get it down unless you have consult 3. I have consult 3 and have been able to get it down through that method.

With consult 3 I’ve also tried to do a roof relearn because I keep getting codes of “roof state lost” but when I follow the steps it doesn’t move the roof at all when it tells me to put it up and down automatically. I’ve seen a lot of threads and people talking about my exact issue of the trunk showing it’s open mid operation and I can say I’ve tried almost everything with no result. The latches are not loose and about every single plug for every single part in the trunk I’ve repluged in to make sure they’re not loose. I’ve seen someone mention the top travel sensor which would make sense for it to be bad but I cannot find where that sensor is, here is a link to the sensor I’ve found:

I have moved the whole convertible top down and up completely manually through consult 3 to make sure everything works mechanically and everything moved perfectly, there has to be some sensor off or some wire messed up that I can’t find or see. Any ideas or help would be greatly appreciated!
Computer Personal computer Output device Font Audio equipment
See less See more
1 - 1 of 1 Posts
1 - 1 of 1 Posts