Infiniti G35 G37 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys, i got a G35 coupe and it wont start, it wont even crank or anything..im thinking its my ignition switch..any ideas or comments?
i put the key, turn the switch then all my dash lights turn on but when i engage the clutch to turn the car on...nothing happens..help please.:confused:
 

·
Registered
Joined
·
66 Posts
The first obvious step would be to check your battery. How old is the battery? could have enough juice to turn on dash lights but not enough to turn your motor. Terminals could be corroded?
 

·
Registered
Joined
·
1,310 Posts
jump it... if it doesnt start after that, try the ignition switch
 

·
Premium Member
Joined
·
27,334 Posts
Ignition switch is probably pretty far down the list of things to check.

Are there any lights on out of the ordinary on the dash?

like they said, check the battery and try jumping it.

if you have one of corded starter switches you might try that too.

I'm not sure what fuse, if any, is in the starter solenoid circuit but I'd check for voltage at the solenoid while the key is turned.

check the clutch switch to make sure it's operating properly
 

·
Registered
Joined
·
57 Posts
If you don't hear clicking noise, it is your starter. get a metal rod or hammer and knock on it few time and it might work temporary
 

·
Premium Member
Joined
·
53,488 Posts
It could be your clutch safety switch which requires you to press the clutch pedal to the floor to start the car. It happened to my coupe. It's an easy $30 part to change. Use a piece of wire as a jumper on the switch harness to see if you can start the car with the jumper. Just be sure it's not in gear.
 

·
Registered
Joined
·
1 Posts
Hey guys, i got a G35 coupe and it wont start, it wont even crank or anything..im thinking its my ignition switch..any ideas or comments?
i put the key, turn the switch then all my dash lights turn on but when i engage the clutch to turn the car on...nothing happens..help please.:confused:
I changed out the starter the cam sensors the crank sensor the O2 sensor. The oil pan. And it won't even crank or start. Oh and a new battery to. I checked most fuses atleast important ones they seem ok.
 
1 - 7 of 7 Posts
Top