Infiniti G35 G37 Forum banner

1 - 2 of 2 Posts

·
Registered
2007 G35 Sport Sedan/6 speed paddle shift
Joined
·
2 Posts
Discussion Starter #1
Hey guys I'm new here. So I've been searching everywhere for some help on my audio issues. I have a 2007 G35 Sport with factory radio, nav, no backup camera. The display shows audio off, which means I have pressed the power button and turned off the radio, I know. But it won't turn back on though. I never turned it off though either. It started as intermittent then went out all the way. It doesn't display a station, a CD doesn't work, nothing. Just displays audio off. I have tested the board and checked for any damage. Everything else works perfectly on it not like most issues where the ac controls don't work. It won't let me access audio controls either but let's me access all others. When I press the tune/audio knob it pops up the music icon in the bottom left corner of the screen as if that part is working but the audio off stays up top. I did pick up a board for the faceplate today at the junk yard but it isn't the right one even though the numbers matched up. The eject button is placed differently and it won't power up anything. Also when I go to the navigation screen it won't let me leave it without leaving the battery undone forever. I can go through setting and all those things but can't leave it. Its driving me insane so any insight will be helpful. I will be picking up another board tomorrow morning that should be the correct one to try it just to be certain it's not that. I'm at a loss on it.
 

·
Registered
2007 G35 Sport Sedan/6 speed paddle shift
Joined
·
2 Posts
Discussion Starter #2
I did the self diagnostic test and it has a red mark for the control unit. Not really sure what control unit it is referring too. There is the ac control unit mounted to the radio but I wouldn't think that it is what its referring too. Also the GPS antenna is grayed out not sure if that means anything. Havent really tried using the navigation.
23389
 
1 - 2 of 2 Posts
Top