Dirver Side HID headlight not working - HELP! - 6MT.net Infiniti G35/G37/GTR Forums
User Tag List

Reply
 
LinkBack Thread Tools
post #1 of 23 Old 03-06-2010, 11:41 AM Thread Starter
25-99 Posts
 
Join Date: Mar 2007
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question Dirver Side HID headlight not working - HELP!

Hey guys, the driver side HID headlight of my o4 Coupe is out... I figured it might have been the bulb, so I went ahead and got 8000K replacements. I swapped the bulbs, but the light driver side HID is still out... I made sure that the connector snaps and twists to the bulb securely.

Could this be a ballast issue? Are there fuses for each headlight?
Oh I should mention that before the light was totally out, it would work sometimes, and sometimes it wouldn't...

Thanks for you help!
G2007 is offline  
Sponsored Links
Advertisement
 
post #2 of 23 Old 03-06-2010, 01:22 PM
Over 1,000 Posts
 
msl558's Avatar
 
Join Date: Mar 2009
Location: Reston, VA
Posts: 1,504
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to msl558
Default

Quote:
Originally Posted by G2007 View Post

Could this be a ballast issue? Are there fuses for each headlight?
Oh I should mention that before the light was totally out, it would work sometimes, and sometimes it wouldn't...

Thanks for you help!
I'm 99% sure it's the ballast IMOE...
msl558 is offline  
post #3 of 23 Old 03-06-2010, 01:43 PM Thread Starter
25-99 Posts
 
Join Date: Mar 2007
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Default

Quote:
Originally Posted by msl558 View Post
I'm 99% sure it's the ballast IMOE...
Is it hard to rewire a new ballast in? Could it be loose wiring? where is the ballast mounted?
G2007 is offline  
 
post #4 of 23 Old 03-06-2010, 07:33 PM
Over 1,000 Posts
 
msl558's Avatar
 
Join Date: Mar 2009
Location: Reston, VA
Posts: 1,504
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to msl558
Default

you can jack ur car up and open the plastic cover by the fender n u will see the ballast. its just behind ur hid. try switching ur ballast before buying
msl558 is offline  
post #5 of 23 Old 03-06-2010, 08:24 PM
ʂȗрϵᴚ ɱȭđěŗƭȱȑ
Lifetime Supporting Member
 
thatguy's Avatar
 
Join Date: Jan 2008
Location: Tulsa, OK
Posts: 27,319
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Default

the ballast is really easy to remove and replace...if you remove the headlight. I'd bet it could be done with the headlight still mounted but you'd be working in tight quarters.

if I remember correctly there is one connector going to the ballast and one connector on the inside the headlight portion. the b!tch of it is the connector lead on the inside is secured with a small screw that is fairly easy to drop.
thatguy is offline  
post #6 of 23 Old 03-06-2010, 08:27 PM
ʂȗрϵᴚ ɱȭđěŗƭȱȑ
Lifetime Supporting Member
 
thatguy's Avatar
 
Join Date: Jan 2008
Location: Tulsa, OK
Posts: 27,319
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Default

if you're tight on funds and have some spare time you might check and see if the driver and pass ballasts are the same pn. if so swap them and if the problem swaps sides then that narrows it down to the ballast. if nothing changes you just saved some dough on a ballast you didn't need...the bad news is you're back to square one trying to figure it out.
thatguy is offline  
post #7 of 23 Old 03-07-2010, 07:38 AM
Super Duper Moderator
Lifetime Supporting Member
 
Gilley's Avatar
 
Join Date: Apr 2005
Location: Orlando, Florida
Posts: 53,459
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 1162 Post(s)
Default

I also think it's the ballast. I think after a few times of failing to come on it shuts down permanently.

'06 Autumn Copper FX35, '11 Alpine White Sentra & 2016 Red Hot Camaro 2SS
Gilley is offline  
post #8 of 23 Old 03-08-2010, 11:38 AM Thread Starter
25-99 Posts
 
Join Date: Mar 2007
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Default

Guys, I found out the issue...it was loose wiring.... I fiddled around with the ballast wiring and hooked up the bulb and BAM! I was blinded by 8000K of brightness! Good thing I didn't go out and buy a new ballast...

Thanks for your suggestions guys.
G2007 is offline  
post #9 of 23 Old 03-08-2010, 12:04 PM
Over 100 Posts
 
eljbird's Avatar
 
Join Date: May 2009
Posts: 220
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

...I just love happy endings
eljbird is offline  
post #10 of 23 Old 03-08-2010, 02:23 PM
Super Duper Moderator
Lifetime Supporting Member
 
Gilley's Avatar
 
Join Date: Apr 2005
Location: Orlando, Florida
Posts: 53,459
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 1162 Post(s)
Default

good thing you didn't have the stock 4300k bulbs in there or you would have been blinded by even more light.

'06 Autumn Copper FX35, '11 Alpine White Sentra & 2016 Red Hot Camaro 2SS
Gilley is offline  
post #11 of 23 Old 03-08-2010, 02:37 PM
Over 1,000 Posts
 
msl558's Avatar
 
Join Date: Mar 2009
Location: Reston, VA
Posts: 1,504
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to msl558
Default

Quote:
Originally Posted by Gilley View Post
good thing you didn't have the stock 4300k bulbs in there or you would have been blinded by even more light.
I know what you meant
msl558 is offline  
post #12 of 23 Old 03-10-2010, 10:10 AM
Over 500 Posts
 
spdcrz's Avatar
 
Join Date: Sep 2008
Location: Van City
Posts: 564
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

I had the same problem.

I thought it was loose wiring because it started working after I moved the wires around a bit. I found out that one of my harness wires was frayed and it needed to be replaced.

So maybe double check that it is not just loose wiring.

SOLD "Pearl" My 04 6mt Fully Loaded Coupe! NOW I have a 2011 G37xS Coupe.... Time to Start Modding!
spdcrz is offline  
post #13 of 23 Old 03-10-2010, 10:01 PM
Super Duper Moderator
Lifetime Supporting Member
 
Gilley's Avatar
 
Join Date: Apr 2005
Location: Orlando, Florida
Posts: 53,459
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 1162 Post(s)
Default

electrical problems can be a pita to figure out.

'06 Autumn Copper FX35, '11 Alpine White Sentra & 2016 Red Hot Camaro 2SS
Gilley is offline  
post #14 of 23 Old 03-11-2010, 07:01 AM
ʂȗрϵᴚ ɱȭđěŗƭȱȑ
Lifetime Supporting Member
 
thatguy's Avatar
 
Join Date: Jan 2008
Location: Tulsa, OK
Posts: 27,319
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Default

like when your distributor rotor shorts out
thatguy is offline  
post #15 of 23 Old 03-11-2010, 03:12 PM
Super Duper Moderator
Lifetime Supporting Member
 
Gilley's Avatar
 
Join Date: Apr 2005
Location: Orlando, Florida
Posts: 53,459
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 1162 Post(s)
Default

right .

It's always the last thing you look at.

'06 Autumn Copper FX35, '11 Alpine White Sentra & 2016 Red Hot Camaro 2SS
Gilley is offline  
Sponsored Links
Advertisement
 
Reply

  6MT.net Infiniti G35/G37/GTR Forums > Infiniti Discussion > G35 Coupe


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
my headlight HID blinks.... HELP krnmasta G35 Coupe 7 07-13-2009 03:19 AM
HID headlight upgrade help Looksfast G35 Coupe 8 05-31-2007 11:10 AM
headlight hid not working G35SR20 G35 Coupe 1 05-29-2007 05:02 PM
Side markers not working G35man G35 Sedan 2003-06 0 04-10-2005 10:29 AM
working on the headlight (projector) heheh accordfreak G35 Coupe 2 01-23-2005 03:44 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome