cd player only works on right side speakers - 6MT.net Infiniti G35/G37/GTR Forums
User Tag List

 
LinkBack Thread Tools
post 1 of 13 Old 04-07-2008, 04:40 PM
0-24 Posts
 
Join Date: Apr 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Default cd player only works on right side speakers

Hey im new to this site and i have a weird situation. ive got a 2004 g35 sedan with stock speakers. When i listen to the radio or the cassette adapter everything works fine. its only when i use the cd player that the left side speakers dont work. every now and then when i make a sharp turn or jerk the car when i brake, sometimes the speaker goes on for a little while. im pretty sure its only the top treble speaker up on the door and not the big one at the bottom because when i change the balance and put it all the way tot the left, you can still hear the bass from the song but nothing else. anyone have any ideas?

thanks alot
ekim3290 is offline  
Sponsored Links
Advertisement
 
post 2 of 13 Old 04-07-2008, 10:22 PM
Over 1,000 Posts
 
pattyskin's Avatar
 
Join Date: May 2007
Location: Tulsa, OK
Posts: 1,673
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

Quote:
Originally Posted by ekim3290 View Post
Hey im new to this site and i have a weird situation. ive got a 2004 g35 sedan with stock speakers. When i listen to the radio or the cassette adapter everything works fine. its only when i use the cd player that the left side speakers dont work. every now and then when i make a sharp turn or jerk the car when i brake, sometimes the speaker goes on for a little while. im pretty sure its only the top treble speaker up on the door and not the big one at the bottom because when i change the balance and put it all the way tot the left, you can still hear the bass from the song but nothing else. anyone have any ideas?

thanks alot
This is a problem with your HU. I had the exact same problem in my G. You have 2 options, if it is under warranty you can have it repalced by infiniti, if it is not buy a Double Din conversion kit and put in an aftermarket system.

(you can smack the center console on the side too and this should make it work again, but really, who wants to do this all the time buy a DD kit !!! )

SOLD THE G
pattyskin is offline  
post 3 of 13 Old 05-31-2008, 09:44 PM
0-24 Posts
 
amnesia's Avatar
 
Join Date: Oct 2007
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

hah, I'm having the exact same problem with my 04 G. My car was still under warranty till last December and every time I took it in for them to look at it, the problem would go away and the mechanics would look at me like I'm crazy. Of course, now that its out of warranty they were able to identify the problem.
amnesia is offline  
post 4 of 13 Old 05-31-2008, 11:38 PM
Super Duper Moderator
Lifetime Supporting Member
 
Gilley's Avatar
 
Join Date: Apr 2005
Location: Orlando, Florida
Posts: 50,631
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 249 Post(s)
Default

Time to buy a used one.

'06 Autumn Copper FX35 & '11 Alpine White Sentra
Gilley is offline  
post 5 of 13 Old 07-11-2008, 06:24 AM
Over 500 Posts
 
G35keys's Avatar
 
Join Date: Jun 2008
Posts: 910
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to G35keys
Default

I've just been graced with this problem this week. If you got the extended warranty they will still replace this correct? I really don't want to replace the radio because of the RDS and I just got XM like 2 months ago(had to buy the tuner/antenna/and the "brain" or whatever)
G35keys is offline  
post 6 of 13 Old 07-11-2008, 07:51 PM
Super Duper Moderator
Lifetime Supporting Member
 
Gilley's Avatar
 
Join Date: Apr 2005
Location: Orlando, Florida
Posts: 50,631
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 249 Post(s)
Default

You'll have to check with your extended warranty contract to see if it is covered.

'06 Autumn Copper FX35 & '11 Alpine White Sentra
Gilley is offline  
post 7 of 13 Old 09-29-2009, 07:14 PM
0-24 Posts
 
Join Date: Sep 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

I had the exact same problem in my 04 coupe. fixed it! The problem is related with the flexible connections inside the radio. They became loose with the time.
Alex81 is offline  
post 8 of 13 Old 10-29-2009, 09:46 PM
Over 100 Posts
 
gq916's Avatar
 
Join Date: Jan 2004
Location: Sacramento, California
Posts: 218
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

same thing happened to mine 4 years ago, it was still under warranty so i took it to the dealership and they had to order me a new one.

1996 Mustang Cobra NA 308rwhp SAE...13.1 @ 110.94
2004 Ivory Pearl with Nismo Factory Body kit
tanabe springs
stillen cat back exhaust
Z tube with k&n
gq916 is offline  
post 9 of 13 Old 12-20-2009, 10:27 PM
0-24 Posts
 
Join Date: Mar 2007
Location: San Diego CA
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

Reply to Alex81: I just noticed my wife's 2004 Bose unit does too. It also has a problem where it'll claim the Siruis is not attached. Pulling the radio fuse for 30 seconds clears the problem. Here's the question: What did you do to fix the loose ZIF / ribbon cable in the HU? Thanks.
hemiboy is offline  
post 10 of 13 Old 11-03-2010, 11:05 AM
0-24 Posts
 
Join Date: Nov 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

Quote:
Originally Posted by hemiboy View Post
Reply to Alex81: I just noticed my wife's 2004 Bose unit does too. It also has a problem where it'll claim the Siruis is not attached. Pulling the radio fuse for 30 seconds clears the problem. Here's the question: What did you do to fix the loose ZIF / ribbon cable in the HU? Thanks.
I just started noticing this same problem with my '04 Coupe as well. Only has 22k miles on it and the speakers (driver's side) are crapping out when the CD player runs. Radio works fine. Does anyone have a process or video on how to fix?
ofanger is offline  
post 11 of 13 Old 11-03-2010, 05:49 PM
Over 1,000 Posts
 
Jake227's Avatar
 
Join Date: Apr 2009
Location: Grand Rapids, Michigan
Posts: 1,159
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

Quote:
Originally Posted by ofanger View Post
I just started noticing this same problem with my '04 Coupe as well. Only has 22k miles on it and the speakers (driver's side) are crapping out when the CD player runs. Radio works fine. Does anyone have a process or video on how to fix?
This is a very common problem with our cars. You need a new head unit. If you are looking for instructions on how to replace the headunit there is a thread on it on G35 driver.com. I have the same problem in mine - but I have an Ipod connector, so I never use my CD player anyway.
Jake227 is offline  
post 12 of 13 Old 11-09-2010, 10:43 AM
0-24 Posts
 
Join Date: Nov 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

Quote:
Originally Posted by Jake227 View Post
This is a very common problem with our cars. You need a new head unit. If you are looking for instructions on how to replace the headunit there is a thread on it on G35 driver.com. I have the same problem in mine - but I have an Ipod connector, so I never use my CD player anyway.
Thanks. That really s*cks. Who wants to buy a new headunit that's going to cost an arm and a leg from the dealer. I like to keep my car factory looking. I guess I'll try to find something used if there are any out there. Thanks again.
ofanger is offline  
post 13 of 13 Old 02-21-2012, 08:25 AM
0-24 Posts
 
Join Date: Feb 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

so does only happen when your playin a cd like does the radio and casette player work fine
thegage is offline  
Sponsored Links
Advertisement
 
Reply

  6MT.net Infiniti G35/G37/GTR Forums > Infiniti Discussion > Audio & Navigation


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
How a computer works? superdude Totally Off Topic 82 01-12-2009 02:46 PM
Speakers cutting out on one side? CK G35 Coupe 21 01-28-2008 03:20 PM
no sound from left side speakers edvin15 Audio & Navigation 1 04-28-2007 07:39 PM
Connect rear side speakers or not? Gilley Audio & Navigation 3 04-21-2005 06:20 PM
Left Side Audio Loss When Using CD Player Kalmairn G35 Coupe 11 03-29-2005 09:01 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome